4. Eclipse - アップデート

 
4.1 概要
4.2 更新の確認
4.3 とりあえず PHP だけ

4.1 概要

 ウェブサイトの PHP のバージョンを 5.6 から 7.2 へあげました。  それでまぁ、Eclipse の PHP 検証バージョンも可能であれば 7.x にしたいな・・・と。  そこではたと、今まで、Eclipse そのものをそっくり変えることは何度もやってきましたが。  本体を変えないまま、モジュールのアップデートをやったことはなかったなと気づきました。  一度やってみます。

4.2 更新の確認

 これでいいのかしら?  と恐る恐る。  「ヘルプ」→「更新の確認」

 何やら、右下でもぞもぞと動いている模様。


 しばらくしたら、こんなん出てきました。
 broken のものがあっても不思議ではない。


 でまぁ、アップデートできるものとしてこういう一覧が出てきましたが


 どうもここで全部選んじゃまずいみたいです。
 全部選んで進んでいったらこんなんなっちゃいました。


4.3 とりあえず PHP だけ

 とりあえず、今回は PHP だけにしておきます。  「次へ」

 「完了」


 ところがこれも前項と同じエラーになってしまいました。
 はて・・・。
 個別のモジュールはアンインストールしてインストールしなおしたほうが良さそうです。