1. FreeBSD - メンテナンス・トラブルシュート - WordPress - アップデートに関して

 
1.1 概要
1.2 バックアップ
1.3 更新 失敗
1.4 更新 再挑戦

1.1 概要

 どうもその
FreeBSD pkg (pkgng)でのカスタマイズ環境アップグレード」

「pkg - FreeBSD入門
 みたいなサイトを読んでいると、WordPresspkg はロックしておいた方がいいのかな・・・。という気がします。  しかし、ロックしてもわたしの場合アップデート自体は、portupgrade で行っているし、pkg の更新状況を見れば、ロックしていても

> pkg version -vl "<"
ja-wordpress-4.8.3                 <   needs updating (index has 4.9)
 てな風に出ちゃうのです。う~ん。と思いつつ・・・。  上記の対応で、portupgrade しようとしたら

> portupgrade -rR ja-wordpress
[Reading data from pkg(8) ... - 397 packages found - done]
[Gathering depends for japanese/wordpress ........................................................................... done]
[Exclude up-to-date packages ................................ done]
--->  Upgrading 'ja-wordpress-4.8.3' to 'ja-wordpress-4.9' (japanese/wordpress)
--->  Building '/usr/ports/japanese/wordpress'
===>  Cleaning for ja-wordpress-4.9
If you want to upgrade, you must read upgrade document.

pkg-static: Bad argument on pkg_set 2143282425
===>  ja-wordpress-4.9 has known vulnerabilities:
ja-wordpress-4.9 is vulnerable:
Wordpress -- multiple vulnerabilities
WWW: https://vuxml.FreeBSD.org/freebsd/a5bb7ea0-3e58-11e7-94a2-00e04c1ea73d.html

1 problem(s) in the installed packages found.
=> Please update your ports tree and try again.
=> Note: Vulnerable ports are marked as such even if there is no update available.
=> If you wish to ignore this vulnerability rebuild with 'make DISABLE_VULNERABILITIES=yes'
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/japanese/wordpress
*** Error code 1

Stop.
make: stopped in /usr/ports/japanese/wordpress
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade20171125-59855-x2lpk4 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=ja-wordpress-4.8.3 UPGRADE_PORT_VER=4.8.3 make
** Fix the problem and try again.
** Listing the failed packages (-:ignored / *:skipped / !:failed)
        ! japanese/wordpress (ja-wordpress-4.8.3)       (security vulnerabilities)
 では、make DISABLE_VULNERABILITIES=yes

> cd /usr/ports/japanese/wordpress
> make DISABLE_VULNERABILITIES=yes
 まではうまくいったんですが

> make reinstall
===>  Installing for ja-wordpress-4.9
===>   ja-wordpress-4.9 depends on file: /usr/local/include/php/main/php.h - found
===>   ja-wordpress-4.9 depends on file: /usr/local/lib/php/20131226-zts/curl.so - found
===>   ja-wordpress-4.9 depends on file: /usr/local/lib/php/20131226-zts/gd.so - found
===>   ja-wordpress-4.9 depends on file: /usr/local/lib/php/20131226-zts/mysqli.so - found
===>   ja-wordpress-4.9 depends on file: /usr/local/lib/php/20131226-zts/tokenizer.so - found
===>   ja-wordpress-4.9 depends on file: /usr/local/lib/php/20131226-zts/xml.so - found
===>   ja-wordpress-4.9 depends on file: /usr/local/lib/php/20131226-zts/zip.so - found
===>   ja-wordpress-4.9 depends on file: /usr/local/lib/php/20131226-zts/zlib.so - found
===>   ja-wordpress-4.9 depends on file: /usr/local/lib/php/20131226-zts/ftp.so - found
===>   Registering installation for ja-wordpress-4.9
*** Error code 70

Stop.
make[3]: stopped in /usr/ports/japanese/wordpress
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/japanese/wordpress
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/japanese/wordpress
*** Error code 1

Stop.
make: stopped in /usr/ports/japanese/wordpress
 うはぁ、しょうがないんで、やったことないんですが、WordPress の機能で更新してみますか・・・。

1.2 バックアップ

 更新ページにいきましたらば・・・。

 まぁ、それはそうですわなぁ。

 データベースは、mysqldump で定期的にバックアップしているので、同じコマンドで


> mysqldump -u root --all-databases -p > mysqldump.sql
Enter password: ← パスワードを入力
 サイトのバックアップは、tar

> tar cvzf 年月日-wordpress.tar.bz2 /ディレクトリ

1.3 更新 失敗

 さあ、これで保険はかけたぞ「今すぐ更新」  げ、FTP なの・・・。

 わたしのマシンは、sftp なのでね・・・。
 sftp のユーザで入力してみたがだめでした・・・。

1.4 更新 再挑戦

 「Wordpressの更新で、FTP経由のアップデートを回避する方法」を参考にして、ユーザ権限を変えまして再挑戦。  FreeBSD の場合、apache ユーザは www ですがね。  再度「今すぐ更新」  動き始めたぞ・・・。

 どうやらうまくいったようです。


 今度は、WordPress を削除せずに portsdb からなくしてしまおうかしら・・・。
 バックアップして make deinstall でうまくいきそうな気はするのですが、それはまた・・・。