12. ntp-devel make DISABLE_VULNERABILITIES=yes

 
12.1 いきさつ
12.2 対処方法

12.1 いきさつ

 ports の更新を確認して
> pkg version -vl "<"
ntp-devel-4.3.93_1                 <   needs updating (index has 4.3.93_2)
 ということでしたので
> portupgrade -rR ntp-devel
 しましたらば
[Reading data from pkg(8) ... - 346 packages found - done]
[Gathering depends for net/ntp-devel .............................................. done]
[Exclude up-to-date packages ................... done]
--->  Upgrading 'ntp-devel-4.3.93_1' to 'ntp-devel-4.3.93_2' (net/ntp-devel)

 ~ 中 略 ~

1 problem(s) in the installed packages found.
=> Please update your ports tree and try again.
=> Note: Vulnerable ports are marked as such even if there is no update available.
=> If you wish to ignore this vulnerability rebuild with 'make DISABLE_VULNERABILITIES=yes'
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/net/ntp-devel
*** Error code 1

 とな。

12.2 対処方法

 言われるとおりにやってみました。
> cd /usr/ports/net/ntp-devel
> make DISABLE_VULNERABILITIES=yes
> make reinstall
 今度はすんなり、いったようです。
> pkg version -v | grep ntp-devel
ntp-devel-4.3.93_2                 =   up-to-date with index
 無事アップデートできました。