FreeBSD - メンテナンス・トラブルシュート - pkg・ports アップデート関連 - shared-mime-info-1.8 → 1.10

 
1. 概要
2. clean してインストール
3. p5-XML-Parser インストール
4. 解決

1. 概要

 2019年02月25日に発生しました。  下記の状況で

> pkg version -vl "<"
shared-mime-info-1.8               <   needs updating (index has 1.10)

> portupgrade -vRr shared-mime-info
--->  Session started at: Mon, 25 Feb 2019 08:48:19 +0900
[Reading data from pkg(8) ... - 375 packages found - done]
[Gathering depends for misc/shared-mime-info .......(devel/pkgconf)(devel/gettext-tools)...(converters/libiconv)(devel/gettext-runtime)..(print/indexinfo)(devel/gmake)..(textproc/intltool)....(textproc/p5-XML-Parser)..(lang/perl5.28)(textproc/expat2)(devel/glib20).............(textproc/docbook-xml)..(textproc/xmlcharent).(textproc/xmlcatmgr)(textproc/docbook-xsl)..(textproc/docbook)...(textproc/docbook-sgml)..(textproc/iso8879).(textproc/sdocbook-xml).(textproc/libxslt)...(security/libgcrypt)...(security/libgpg-error).....(print/texinfo)..........(misc/help2man)......(devel/p5-Locale-gettext)...(devel/p5-Locale-libintl)....(converters/p5-Text-Unidecode).(textproc/p5-Unicode-EastAsianWidth).(textproc/libxml2)...(lang/python36)......(security/openssl).(devel/libffi).(devel/readline).(devel/pcre) done]
[Exclude up-to-date packages .................................. done]
--->  Upgrade of misc/shared-mime-info started at: Mon, 25 Feb 2019 08:48:23 +0900
--->  Upgrading 'shared-mime-info-1.8' to 'shared-mime-info-1.10' (misc/shared-mime-info)

・・・	略	・・・

===>   shared-mime-info-1.10 depends on shared library: libxml2.so - found (/usr/local/lib/libxml2.so)
===>  Configuring for shared-mime-info-1.10
configure: loading site script /usr/ports/Templates/config.site
checking for a BSD-compatible install... /usr/bin/install -c

・・・	略	・・・

checking for perl... /usr/local/bin/perl
checking for perl >= 5.8.1... 5.28.1
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
===>  Script "configure" failed unexpectedly.
Please report the problem to gnome@FreeBSD.org [maintainer] and attach the
"/usr/ports/misc/shared-mime-info/work/shared-mime-info-1.10/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/misc/shared-mime-info
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade20190225-61513-1eyq5r9 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=shared-mime-info-1.8 UPGRADE_PORT_VER=1.8 make
** Fix the problem and try again.
--->  Build of misc/shared-mime-info ended at: Mon, 25 Feb 2019 08:48:25 +0900 (consumed 00:00:01)
--->  Upgrade of misc/shared-mime-info ended at: Mon, 25 Feb 2019 08:48:25 +0900 (consumed 00:00:01)
--->  ** Upgrade tasks 1: 0 done, 0 ignored, 0 skipped and 1 failed
--->  Listing the results (+:done / -:ignored / *:skipped / !:failed)
        ! misc/shared-mime-info (shared-mime-info-1.8)  (configure error)
--->  Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed
--->  Session ended at: Mon, 25 Feb 2019 08:48:25 +0900 (consumed 00:00:05)

2. clean してインストール

 この手の状況のときは、とりあえず、clean して make し直してみます。

cd /usr/ports/misc/shared-mime-info/
make deinstall clean
make
 make の時点で

> make
===>  License GPLv2 accepted by the user
===>   shared-mime-info-1.10 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by shared-mime-info-1.10 for building
===>  Extracting for shared-mime-info-1.10
=> SHA256 Checksum OK for shared-mime-info-1.10.tar.xz.
===>  Patching for shared-mime-info-1.10
===>  Applying FreeBSD patches for shared-mime-info-1.10
===>   shared-mime-info-1.10 depends on package: pkgconf>=1.3.0_1 - found

・・・	略	・・・

===>   shared-mime-info-1.10 depends on shared library: libxml2.so - found (/usr/local/lib/libxml2.so)
===>  Configuring for shared-mime-info-1.10
configure: loading site script /usr/ports/Templates/config.site
checking for a BSD-compatible install... /usr/bin/install -c

・・・	略	・・・

checking for perl... /usr/local/bin/perl
checking for perl >= 5.8.1... 5.28.1
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
===>  Script "configure" failed unexpectedly.
Please report the problem to gnome@FreeBSD.org [maintainer] and attach the
"/usr/ports/misc/shared-mime-info/work/shared-mime-info-1.10/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/misc/shared-mime-info
 落ち着いてよく読むと「XML::Parser」がないと言っています。  「perl5.26」から「perl5.28」にアップグレードした際についていってないのかしら?

> whereis p5-XML-Parser
p5-XML-Parser: /usr/ports/textproc/p5-XML-Parser
 これをインストールすればいいんかな?

3. p5-XML-Parser インストール


cd /usr/ports/textproc/p5-XML-Parser
make
make install
 これも一回エラーがでまして

cd /usr/ports/textproc/p5-XML-Parser
make deinstall clean
make
make install

4. 解決

 その後

cd /usr/ports/misc/shared-mime-info/
make deinstall clean
make
make install
 これで、無事アップグレードできました。
 
 
カウンタバックグラウンド