18. メンテナンス・トラブルシュート - pkg・ports アップデート関連 - llvm60-6.0.0_3 → 6.0.0_4

 
18.1 概要
18.2 よくわからない解決

18.1 概要

 発生は 2018年5月16日。

> pkg version -vl "<"
llvm60-6.0.0_3                     <   needs updating (index has 6.0.0_4)
 つ~んで。  portupgrade したら下記のようになって止まっちゃいました。

llvm-6.0.0.src/test/tools/llvm-rc/Inputs/tag-accelerators-too-long.rc: Failed to create dir 'llvm-6.0.0.src/test/tools/llvm-rc'
llvm-6.0.0.src/test/Transforms/DeadArgElim/deadexternal.ll: Can't create 'llvm-6.0.0.src/test/Transforms/DeadArgElim/deadexternal.ll'
tar: Error exit delayed from previous errors.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/llvm60
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/llvm60
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade20180516-6052-1363mph env UPGRADE_TOOL=portupgrade UPGRADE_PORT=llvm60-6.0.0_3 UPGRADE_PORT_VER=6.0.0_3 make
** Fix the problem and try again.
** Listing the failed packages (-:ignored / *:skipped / !:failed)
        ! devel/llvm60 (llvm60-6.0.0_3) (unknown build error)
 ほぼ同じような構成の別のマシンでは何事もなくアップデートできたのに・・・。

18.2 よくわからない解決

 実に不思議なのですが・・・。  もう一度、portupgrade したら、正常に終了したのです。  よくわからない。