1.1 メンテナンス・トラブルシュート - pkg・ports アップデート関連 - 11.0 RELEASE portupgrade インストールエラー

 
1.1.1 概要
1.1.2 応急処置

1.1.1 概要

 2018年1月22日、インストール直後の FreeBSD 11.0 RELEASE で  /etc/portsnap.conf の編集後

> portsnap fetch
> portsnap extract
 /etc/make.conf の編集後

> cd /usr/ports/ports-mgmt/portupgrade
> make
 の時点で

===> Building/installing dialog4ports as it is required for the config dialog
===>  Cleaning for dialog4ports-0.1.6
/!\ ERROR: /!\

Ports Collection support for your FreeBSD version has ended, and no ports are
guaranteed to build on this system. Please upgrade to a supported release.

No support will be provided if you silence this message by defining
ALLOW_UNSUPPORTED_SYSTEM.

*** Error code 1

Stop.
make[3]: stopped in /usr/ports/ports-mgmt/dialog4ports
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/ports-mgmt/dialog4ports
===> Options unchanged
/!\ ERROR: /!\

Ports Collection support for your FreeBSD version has ended, and no ports are
guaranteed to build on this system. Please upgrade to a supported release.

No support will be provided if you silence this message by defining
ALLOW_UNSUPPORTED_SYSTEM.

*** Error code 1

Stop.
make[1]: stopped in /usr/ports/ports-mgmt/portupgrade
*** Error code 1

Stop.
make: stopped in /usr/ports/ports-mgmt/portupgrade
 どうも、サポートしていないバージョンの OS に対して ports がより厳しくなっているようです。  根本的な解決方法は、バージョンアップしかないようです。

1.1.2 応急処置

 調べてみたところ、応急処置で

setenv ALLOW_UNSUPPORTED_SYSTEM
 と環境変数を設定すれば、ワーニングにはなるものの、うまくいけばアップデートできるとのこと。  やってみるしかないですな。